PCI-DSS 3.1 Now Requiring Yearly Penetration Testing for eCommerce Merchents

Discussion in 'Payment Card Industry News And Announcements' started by CyberSecurityAgency, Oct 8, 2015.

  1. CyberSecurityAgency

    CyberSecurityAgency New Member

    With the release of the new PCI-DSS 3.1 eCommerce merchants need to be ready for the required Penetration Testing that most merchants will now need to have done annually. When budgeting for 2016 operating expenses you may need to plan for an additional expense in excess of $3,000 for small business networks and upwards of $15,000 for medium size merchants.

    Scott D.
    Cyber Security Agency
    www.CyberSecurityAgency.org
    866-898-3218
     

Share This Page